Blog Posts

  1. Samsung Galaxy S5 and S6 SwiftKey Vulnerability

    A message from Samsung:

    "You may be hearing about the Samsung SwiftKey vulnerability in the news. If you use a Samsung Galaxy phone, as a security best practice, we recommend that your device is configured to automatically receive the security update from Samsung once it is available. If you have questions about the security update, you should contact your carrier. We also recommend that you minimize the use of unsecure wireless networks for private information such as mobile banking until the security update is available."

    Read Samsung’s full statement for more information. Also, Delta Community’s security guidance is to avoid conducting sensitive transactions over unsecure networks at all times.

    Posted: June 25, 2015 by Delta Community
    Filed under: security